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1 Introduction

1.1 Purpose

This document is the user manual of the EMF-VISUAL software.

2 Presentation

2.1 What EMF-VISUAL is

EMF-VISUAL simulates scattered fields from GSM antennas in a 3D virtual database using ray-
tracing techniques. EMF-VISUAL can visualize raw computed fields or safety limitation areas defined
by any recommendation.

EMF-VISUAL runs on a single PC system.

2.2 Input/Output

2.2.1 Input

• *.scnx The input data of a EMF-VISUAL simulation is a configuration file. Moreover, EMF-VISUAL
can import configuration file (*.iconf ) from EMF-Visual V3, the previous version.

• *.bdd Files that define the geometry of an environment.

• *.evc Recommendation files.

• *.txt Custom standard files.

2.2.2 Output

• Simulation results in Tecplot format.

2.2.3 Licence

EMF-VISUAL requires EMF-VISUAL licence. Contact OKTAL-SE (http://www.oktal-se.fr)

2.3 Operating systems

EMF-VISUAL is available on:

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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OS 32-bit executable 64-bit executable

Windows XP 32-bit OK -

Windows XP 64-bit OK OK

Windows Seven 64-bit OK OK

The software requires a graphics card with 3D acceleration if GPU computation is performed and a
three-button mouse. NOTE: EMF-VISUAL may use GPU resources for its simulation. Only NVIDIA
CUDA-enabled GPUs (version 9 or higher) can run the software. Compatible configurations are listed
at: http://www.nvidia.com/object/cuda_gpus.html (COMPUTE CAPABILITY>= 1.1).

2.4 Launching EMF-VISUAL

The executable of EMF-VISUAL depends on version.

Here are the valid launcher:

• 32 bits version: Software\Program_Win32\EMF-VISUAL\EMF_VISUAL.exe
• 64 bits version: Software\Program_Win32\EMF-VISUAL_64\EMF_VISUAL.exe

Note: Executable under Software\Program_Win32\Bin\EMF-VISUAL\EMF-VISUAL.exe or
Software\Program_Win32\Bin_64\EMF-VISUAL\EMF-VISUAL.exe are not meant to be launched.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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3 Software overview

3.1 Main window

Figure 1: Main window

The main window of EMF-VISUAL is composed of:

• A menu bar (1) that contains the main commands of the software

• A general toolbar (2) for scene management.

• A central area (3) that displays both 3D scene and simulation results (fields, recommendation
area). A specific toolbar (4) provides functionalities to control 3D view.

• Five dock windows that are initially placed around the central area:

• The "Browser" window (5): this dock window contains the panels dedicated to Scene’s
edition, computation Tool’s edition.

• The "Properties" window (6): this dock window sets parameters of selected entity.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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• The "Computation results" window (7): this dock window sets result to display with several
parameters and kind of visualisation.

• The "Recommendation property" window (8): this dock window defines recommendation
file.

• The "Messages" window (9): this dock window displays all messages.

3.2 Files operation

A configuration file is an XML document with the .scnx extension.

To create a new scenario, select the New (Ctrl + N) command from the File menu.

To load an existing scenario, select the Open... (Ctrl + O) command from the File menu.

To import an old configuration file in .iconf format, select the Import... command from the File
menu. See 4.5 for more details.

To save the current scenario, select the Save (Ctrl + S) command from the File menu.

To save the current scenario under a new name, select the Save as... command from the File
menu.

3.3 Using dock windows

Each dock window has in a title bar and a content area. The title bar displays the window title
("Scenario" for example), a float button and a close button . A dock window can have different states:

• The docked state (the default one): in this state, the dock window is visible and placed on the
east, west, north or south side of the central area. To move a dock window, click on its title bar
with the left mouse button, hold it down while moving the mouse at the new emplacement and
release the mouse button.

• The floated state: in this state, the dock window floats above the workspace. To toggle the state
of a dock window from docked to floated and vice-versa, click on its float button.

• The hidden state: in this state, the dock window is hidden. To hide a dock window, click on
its close button. To retrieve a dock window that has been hidden, click with the right button of
the mouse on the title of an another dock window or on the toolbar. The following window will
appear.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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Figure 2: Dock windows management

Select the dock window to retrieve by clicking on its title. In a more general approach, this
window is a central place to manage the visibility of all dock windows and toolboxes.

When a dock window is floated or hidden, the area that it frees inside the workspace can be occupied
by a view, making its manipulation more comfortable. The picture below shows the software with all
dock windows hidden.

4 Scene management

There is no computation without any 3D database. This section shows how to build a 3D scene with
EMF-VISUAL.

4.1 Creating a scene

Entities of the scene are under the Scene node.

Figure 3: Scene node

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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There are several kind of entities. To add an entity Right click on Scene node > Add Entity. You
can choose among the following entities

• Object
• Group
• Antenna

Another way to add entity is to right click on view windows, a panel will be displayed: Right click on
view window > Add Entity

Position and orientation properties are under Properties dock widget.

Every entity can be moved with moving tools described in previous chapters( See 4.3.4 and 4.3.5)

4.1.1 Object

4.1.1.1 Geometry representation

An object entity represents a solid actor using a geometry file. It is taken into account during the
electromagnetic computation. To add an object entity: Right click on Scene node > Add Entity >
Object. One can choose a geometry file from the displayed file browser. An object file is a *.bdd
(SDM geometry files) or *.bsg (OpenSceneGraphe files). The Scene node acts as an object entity,
except that it is unique and can not be positioned.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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4.1.1.2 Object properties

Figure 4: Object properties

• Open new geometry file. Select the new file from the displayed file browser.

• Remove current geometry file.

One can modify the size of entity along X,Y,Z dimension with parameters (Width,Depth,Height).

4.1.1.2.1 Material definition

A good geometry is not enough for EM computation, a well definition of material with correct physical
property is required. EMF-Visual allows user to set material to object.

Click on EM Material box to set material to object from a list of predefined materials.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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Figure 5: List of predefined materials

Open the material manager window, Simulation > Display material manager to get physical prop-
erties (permittivity, conductivity and thickness) of materials.

Figure 6: Material Manager window

4.1.2 Group

This entity has no interaction with the electromagnetic computation. It is useful for moving several
entities attached to it. To add an object entity: Right click on Scene node > Add Entity > Group

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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4.1.3 Antenna

An antenna entity represents a electromagnetic antenna using an antenna description file. It is taken
into account during the electromagnetic computation. To add an antenna entity: Right click on
Scene node > Add Entity > Antenna. An antenna file is a *.src. An antenna may be composed of
several bands.

Figure 7: Multi bands

4.1.3.1 Band properties

Figure 8: Multi bands

• Name Name of the band
• Gain Gain of antenna in this band
• Electric tilt ( ◦) Electric tilt in degree.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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• Frequency (MHz) Frequency of the band in MHz
• Power (W) Power in Watt
• Enabled If unchecked, this band is disabled.

4.1.3.2 Antenna properties

Figure 9: Antenna properties

• Checking Show radiation area box displays the radiation field in the 3d window.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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Figure 10: Antenna radiation area

• Open new antenna file *.src. Select the new file from the displayed file browser.

• Horizontal aperture is expressed in degree. It can’t be edited.

• Vertical aperture is expressed in degree. It can’t be edited.

4.1.4 Camera

Camera entity defines the point of view of the view window of EMF-Visual.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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Figure 11: Camera properties

• Near plane (m) defines the distance of the near plane of the view. Every geometry in the field
of view before the near plane is not rendered in view window.
• Far plane (m) defines the distance of the far plane of the view. Every geometry in the field of

view above the far plane is not rendered in view window.
• Aperture ( ◦) defines the aperture of the camera.

4.2 Edit tool bar

Figure 12: Edit Tool Bar

4.2.1 Edition tool bar

Figure 13: Edition tool bar

Standard entity edition tool bar.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
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• Cut selected entity in scene hierarchy

• Copy selected entity in scene hierarchy

• Paste copied entity under selected entity hierarchy

• Remove selected entity from scene hierarchy

4.2.2 Hierarchy tool bar

Figure 14: Hierarchy move tool bar

The edit tool bar allows to change position of entity in the scene hierarchy.

• Move selected entity up in scene hierarchy

• Move selected entity down in scene hierarchy

• Move selected entity up in scene hierarchy

• Move selected entity up in scene hierarchy

4.2.3 Distance tool bar

Figure 15: Distance tool bar

The distance tool measures distance between 2 points.

• Clicking on button creates a Distance entity in Tools node and adds the first point.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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Figure 16: Distance tool: first point

The first point is selected after it has been created and can be moved using Move tool (see
4.3.4), Dragger tool (see 4.3.5) or changing position in properties panel (see 4.2.5).

• Clicking on button adds the second point.

Distance between these 2 points is displayed

◦ in Tools node

Figure 17: Distance in Tools node

◦ in 3d view scene

Figure 18: Distance in 3d view

The second point is selected after it has been created and can be moved using Move tool (see
4.3.4), Dragger tool (see 4.3.5) or changing position in properties panel (see 4.2.5).

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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The distance is updated while changing second or first point position.

4.2.4 Browser

Each entity of the scene can be selected in this dock window. Properties of selected entity are
displayed in "Property" window and may change depending on kind of selected entity.

Figure 19: Dock windows management

When the SHIFT key is pressed, a group of entity can be selected. Clicking on an entity while CTRL
key is pressed, appends it to the current selection.

There are 2 main nodes: Tools node and Scene node. Tools node contains utility entities:

• Distance. See 4.2.3.
• Volume for computation
• Plane for cross section visualization.

In the browser window, a checked entity is an activated entity.

Figure 20: Checked entity

A checked entity is visible in the 3d view window and is taken into account for computation.

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
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Figure 21: Unchecked entity

An unchecked entity is not visible in the 3d view window. Moreover, depending on type of the entity,
it will not be taken into account the same way.

• Geometry The geometry of entity is not taken into account for computation
• EntityGroup All entities under the EntityGroup are not taken into account
• Antenna The field emitted by the antenna is not computed for activated volumes.
• Volume The field from valid antennas is not computed inside the unchecked volume.
• Plane The cross section is not computed.

4.2.5 Property

This dock window show property for selected entity.

Figure 22: Position and orientation properties

Properties are different from a kind of entity to another but they share at least the same position and
orientation properties

• X
• Y
• Z
• Azimuth
• Tilt
• Roll

A position is represented with conventional (X, Y, Z) coordinates which are expressed in meters.
An orientation is represented with a (Azimuth, Tilt, Roll) triplet (also called Euler angles) whose

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
and cannot be duplicated nor distributed without the written agreement of the company.
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components are expressed in degrees. The azimuth value is a rotation about the Z axis and is
positive clockwise if looking along the +Z axis. The tilt value is a rotation about the X axis and is
positive above the XY plane. The roll value is a rotation about the Y axis after head and pitch have
been applied and is positive clockwise if looking along the +X axis.

Figure 23: Reference

4.3 View tool bar

Figure 24: View tool bar

4.3.1 Observers selection

Figure 25: Observers selection

The option is limited to one camera.

4.3.2 Selection tool

To activate the selection tool, Click on button or press the S key. Then, selecting is performed
by left clicking on an entity. When the CTRL key is pressed while clicking, the picked element is

All the information included in this document remains the exclusive property of OKTAL SYNTHETIC ENVIRONMENT ©
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appended to the selection.

4.3.3 Information tool

To activate the information tool, Click on button or press the I key. This tool displays a dialog
providing information about picked point. Then Click on a point in 3d view window to get information
about it. By default, before clicking on a point, no element is picked.

Figure 26: Information window

The displayed information about the
picked element is:
• its name
• its type
• its absolute position
• its absolute orientation

The displayed information about the
picked point is:
• its absolute position
• its distance to the observer
• the path of the texture picked

4.3.4 Move tool

Move tool allows the user to set position of the currently selected entity on the scene from 3d view.
To activate the Move tool, Click on button or press the M key. Then, left click on the scene to
move the currently selected entity or control point to the designated location. The user has to left
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click on entity so that selected entity is moved.

4.3.5 Dragger tool

Dragger tool allows moving and orientating the currently selected entity by manipulating a 3D drag-
ger.
To activate the dragger tool, Click on button or Press D key. To move an entity, Left Click on
one of the dragger’s axes and drag it to the desired position. To orientate an entity, left click on one
the dragger’s rings and drag it to rotate the dragger.

Figure 27: Dragger tool activated on object

While dragger tool is activated, Press Space Bar to switch the dragger type from moving and rotating
mode to scaling mode and the contrary.
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Figure 28: Dragger tool in scale mode

4.3.6 Handling a scene

4.3.6.1 Centred navigation mode

EMF-Visual uses the centred navigation mode. The observer moves around a centre point picked in
the scene.

Keep the middle mouse button pressed and move the mouse to change view direction. The
position and orientation are not modified. By default, the centre point is the centre of the scene.

Figure 29: Centred navigation modes

Centring mode can be selected in a combo box in View tool bar:

• Center On Point : Click on Center On Point action or press C key then click on specific point in
the scene that will be the centre.
• Center On Entity : Click on Center On Entity action then select the entity among the entities list

that will be the centre.
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• Center On Selection: Click on Center On Selection action, the centre of the last selected object
will be the centre of the view. It requires to have already selected at least one object.

4.3.6.2 Pan navigation mode

Keep H key pressed - the cursor of the mouse changes to an hand( ) - keep the left mouse
button pressed and move the mouse to translate view direction.

Releasing H key switches back to centred navigation mode.

4.3.6.3 Zoom

Scroll up the wheel of the mouse to zoom in, scroll down the wheel to zoom out.

4.3.7 View Settings

Click on to display View settings panels.

Figure 30: View Setting panels
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4.3.7.1 General panel

Figure 31: General panel

This panel defines a rendering configuration of the view. To change the kind of the overlay statistics
(i.e. information drawn above the image) , select one of the entry from the "Statistics" drop down list:

• None No statistics are displayed (default)
• Frame rate The frame rate (Hz) is displayed in the rendering window
• Timings A chart containing the timings of each stage of the rendering pipeline is dis-

played in the rendering window
• Scene geometry The frame rate, the number of rendered vertices and triangles are displayed

in the rendering window

To change the draw style of the rendering , select one of the entry from the "Draw style" drop down
list:

• Wireframe Only the edges of the polygons are rendered
• Filled The polygons are rendered without the textures
• Textured The polygons are rendered with the textures (default)
• Scribed The edges of the polygons are rendered over the textures

The alpha threshold is used to discard transparent pixels. Every pixels whose alpha is below the
threshold are not rendered. The default value is 0.7.
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When the "Activate shaders" item is checked , the rendering pipeline uses the programmable shaders
instead of the fixed functionality of the graphics card, and allows several specific objects (such as
water hyper-textures) to be rendered with more realism. This check box is disabled if there is no
NVIDIA graphic board.

When the "Frame overlay" item is checked , a 3D frame is displayed at the top-right corner of the
view.

To configure how the resolution of the rendered image is handled , select an entry from the "Image
resolution" drop down list:

• Extend for observer/Crop for sensor: The image is extended to the window size if the default
observer is selected. When a sensor is selected, the image is cropped to its resolution.
• Always extend: The image is always extended to the window size.
• Always crop: The image is always cropped to the resolution of the selected camera.

4.4 Editing the search directories

4.4.1 Purpose

The scene structure refers to several files needed for the computation. These files can be 3D geom-
etry files, antenna diagram, etc... When saving a configuration file, these dependencies are written
relatively to the scene file path (if there are on the same disk partition). A dependency may also refers
to other files. To cope with multiple recursive references, paths to all references are added to search
directories. Search directories are saved in an environment file .env with the same configuration file
name.

4.4.2 Search directory panel

To edit the search directories of the current configuration. Edit > Search directories
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Figure 32: Scene node

• Add a new path to the search directories. Select the new directory from the displayed file
browser.

• Remove the selected path from the search directories.

The order of the search directories list is meaningful. During the search process, the path at the
beginning of the list will be first explored, then the second, and so on.

• Increase the priority of selected path, i.e. grant it a higher rank in the list

• Decrease the priority of selected path, i.e. grant it a lower rank in the list

4.4.3 Refresh the scene

Refreshing the scene will take into account edited search directories. File > Refresh all.

4.5 Importing scene

To insure backward compatibility, EMF-VISUAL can import *.iconf from EMF-VISUAL V3.x.

To import a scene in *.iconf file format: File > Import
Select the output directory from the displayed file browser. Data_Objects and Data_Scnx will be
created.
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Edit the search directory to add Textures directory see 4.4 Editing the search directories. Indeed,
just after importing a scene, entities will appear without texture. Appending directory to Textures will
set textures to geometry.

4.6 Tools node

Under the Tools node, only computation volume and cut plane for cross section visualisation are
allowed.

4.6.1 Volume

See 5.1 Computation volume

4.6.2 Plane

See 5.3.1.2 Cross section

5 Simulation management

5.1 Computation volume

EMF-Visual is meant for field computation on volume. This volume has to be sampled for computa-
tion. Defining a volume requires 2 steps.

• first step: Defining size and position of the volume
• second step: Defining the sampling of the volume.

Note that no computation is launched if no computation volume is defined.

Note : The software handles several computation volumes.

To add a computation volume. Right click on Tools node > Add entity > Volume

A volume added in Scene node is not taken into account for computation
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Figure 33: Computation Volume

5.1.1 Volume properties

Figure 34: Volume properties

A volume is defined by its size in the 3 dimensions.

• Width Size in X dimension
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• Depth Size in Y dimension
• Height Size in Z dimension

5.1.2 Sampling of the volume

Figure 35: Computation grid type

A computation grid defines the way to sample the volume for computation. In EMF-Visual, 3 types of
sampling are available.

• Regular grid The volume is sampled along the 3 dimensions with the same sampling step.

X

Z

Y

Figure 36: Grid volume regular

• Irregular grid The sampling along an axis depends on a far distance from EM source along this
axis. This far distance is the same for the 3 axis.
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Figure 37: Grid volume irregular

• Irregular grid per axis The sampling along an axis depends on distance from EM source along
this axis. Far distances may be different for the 3 axis.
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Figure 38: Grid volume irregular per axis

For each computation volume, each antenna, each band, and each polarisation, EMF-Visual
creates one computation result file. Result files are created in folder Results under the same
directory than the configuration file.

5.2 Launch computation

To launch a computation, Simulation > Run
NB: A volume must have been defined.
The results files are saved in Tecplot format under a directory which name is:
<SceneFileName>_<Year><Month><Day>_<Hour><Minute><Second>-<ComputationMode>.
There are as many files as antenna bands. The name of result file is
"<SceneFileName>_Volume_<VolumeIndex>_AntennaBands_<BandsIndex>.txt".

• <SceneFileName> is the name of the scene file without .scnx extension
• <VolumeIndex> is the index of the computation volume.
• <BandIndex> is the index of the band of for all active antennas.
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• <Year><Month><Day>_<Hour><Minute><Second> are the year, month, day, hour, minute and second
of the computation.
• <ComputationMode> is "GPU-Advanced" or "CPU-Standard" depending on the version of EMF-VISUAL.

NB: A .dat file is also create which is the binary version for results file.

5.2.1 Results file format

Here the Tecplot file format of result file.

5.2.1.1 Header

#Date: <Date>
#Computation on <CPUorGPU> in <StandardOrAvanced> mode
#Volume matrix
<Matrix>
#Frequency
#<Frequency>
#Antenna Properties
#Antenna Name: <AntennaName
#Band Name: <BandName>
#Name: <AntennaName>
TITLE = "EMF-FIELD"
VARIABLES = "X", "Y", "Z", "ExModule", "ExPhase", "EyModule", "EyPhase",
"EzModule", "EzPhase"
ZONE T="Data",
I=<PointsCount>, J=1, K=1, F=POINT

With

• <Date> Date of computation in format <Year>-<Month>-<Day> <Hour>:<Minute>:<Second>
• <CPUorGPU> CPU if computation was performed in CPU mode, GPU otherwise.
• <StandardOrAvanced> Standard if computation was performed in standard mode, Advanced oth-

erwise
• <Matrix> For internal use, the 4x4 matrix defining the position and orientation of the

volume
• <Frequency> The frequency of the band in Hertz
• <AntennaName> The name of the antenna defined in .src antenna file
• <BandName> The name of the band defined in .src antenna file
• <AntennaID> The ID of the antenna
• <PointsCount> The number of computed points of the volume.
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5.2.1.2 Raw data

Results for one computation point are stored line by line. By order a line is composed of

• X coordinate of computed point in meters
• Y coordinate of computed point in meters
• Z coordinate of computed point in meters
• Module of electric field in X axis in V/m
• Module of electric field in Y axis in V/m
• Module of electric field in Z axis in V/m
• Phase of electric field in X axis in radians
• Phase of electric field in Y axis in radians
• Phase of electric field in Z axis in radians

5.3 Results visualisation

EMF-Visual can display one result computation at a time.

Figure 39: Computation Result

To view a computation result

• Check Show Results
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• Open new result directory. Select the new directory file from the displayed file browser.

• Select unit among a list

◦ Electric Field (V/m)
◦ Electric Field (dBV/m)
◦ Electric Field (dBmV/m)
◦ Electric Field (dBµV/m)
◦ Magnetic Field (A/m)
◦ Magnetic Field (dBA/m)
◦ Power Density (W/m2)
◦ Power Density (mW/cm2)
◦ Power Density (µW/cm2)
◦ Field Percentage (public)
◦ Field Percentage (worker)
◦ Power Percentage (public)
◦ Power Percentage (worker)

• Min legend and Max legend are min and max values used to display results.
Clicking on retrieves min or max value from data.

Results can be visualised with cross section or with iso surfaces once a data file is loaded,

5.3.1 Visualisation

5.3.1.1 Isosurface

To vew iso-surface Check Iso-surface level.The slider will change value of iso-surface to display.

Figure 40: Iso-surface view
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5.3.1.2 Cross section

To display a cross section, a plane has to be added to Tools node. Right click on Tools node > Add
entity > Plane

Figure 41: Plane in Tools node

Once a plane added to Tools node, it will define a cut plane. Moving and orientating it will update
view of cut plane.
Note that several planes can be added.
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Figure 42: Plane properties

The plane is modelled in the 3D view by a flat box as below with grid for visualisation. The plane is
display only when it is selected.
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Figure 43: Plane visualisation

The thickness of this box can’t be changed. Modifying the height of the box has no effect.

5.3.1.2.1 Plane property

3 pre defined planes can be chosen in EMF-Visual.

Figure 44: Plane orientation property
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XY Plane XY Plane XY Plane

5.3.1.2.2 Clipping property

If clipping property is not set to Off, the defined plane cuts every object in the scene, including iso-
surfaces.

•
Positive Iso-surface
in positive side of
plane is cut

•
Negative Iso-surface
in negative side of
plane is cut
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5.3.1.2.3 Grid properties

Figure 45: Plane grid property

The sampling of the visualisation grid can be set for each dimension.

Figure 46: 1m sampling Figure 47: 2m sampling

5.3.2 Recommendation file

Recommendation file is a *.evc file.

Open new recommendation file *.evc. Select the new file from the displayed file browser. See
6.3 for default recommendation example files.

Once a recommendation file loaded, several areas are displayed depending on the recommendation

• Public area
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• Worker area
• Forbidden area

Figure 48: Recommendation example

A recommendation file defines the limits between each area.

Values from recommendation can be modified.

Figure 49: Recommendation properties

5.3.3 Recommendation

Recommendation to apply for exposure computation can be chosen among 4 different recommenda-
tions:

• ICNIRP - European Union recommendation
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• Safety Code 6-2015 - Canada recommendation
• FCC - Us recommendation, FCC Reference Levels June 2013
• Custom - Customized recommendation, defined by user in a file. See 5.3.4

Figure 50: List of recommendations

5.3.4 Custom standard file

A custom standard file is an ascii *.txt file

Open custom standard file *.txt. Select the new file from the displayed file browser. This field is
not editable if Custom recommendation is not selected.

This file provides coefficients for computing reference electric value to display Field or Power Per-
centage for public and restricted environments.
NB: Magnetic reference values are deduced from electric reference values with the formula
H = E/120π

5.3.4.1 Genenic reference value computation formula

For a range of frequencies, the generic formula to compute reference value is:

ref = a · f b

with

• f frequency in MHz
• a and b coefficients provided by custom standard file.

5.3.4.2 Custom standard file format

A custom standard defines coefficients (a, b) for different ranges of frequencies and for public and
restricted or worker environments.
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n
aP0 a

P
1 . . . aPn

bP0 b
P
1 . . . bPn

fP
0 f

P
1 . . . fP

n−1

m
aW0 aW1 . . . aWm
bW0 bW1 . . . bWm
fW
0 fW

1 . . . fW
m−1

with

• n the number of frequencies for defining ranges of frequencies for public environment
• aPi the coefficient a number i for public environment
• bPi the coefficient b number i for public environment
• fP

i the frequency number i in MHz used to define ranges of frequencies for public environment
• m the number of frequencies for defining ranges of frequencies for worker environment
• aWi the coefficient a number i for worker environment
• bWi the coefficient b number i for worker environment
• fW

i the frequency number i in MHz used to define ranges of frequencies for worker environment

Let f be the frequency of an electromagnetic source expressed in MHz.

Let refP be the reference value for public environment and refW the reference value for worker
environment.

refP =


aPi · f bPi if fP

i ≤ f < fP
i+1 with i 6= n− 1

aP0 · f bP0 if f ≤ fP
0

aPn · f bPn if fP
n−1 < f

refW =


aWi · f bWi if fW

i ≤ f < fW
i+1 with i 6= m− 1

aW0 · f bW0 if f ≤ fW
0

aWn · f bWn if fW
m−1 < f

Be careful, there are n + 1 coefficients
(
aPi , b

P
i

)
and n frequencies fP

i . Frequencies define limits of
frequency ranges and the coefficents are defined for each frequency range. The same for worker
environment definition, there are m+ 1 coefficients

(
aWi , b

W
i

)
and m frequencies fW

i .

NB: The separators allowed between each values are: space, tabulation, carriage return. The layout
of the custom standard file in this document is a suggestion for an easy reading. If the custom stan-
dard file is wrong, message "Custom standard file error" is displayed and ICNRP recommendation is
used by default.

5.3.4.3 Example of custom standard file

Here an example of custom standard file which fits the ICNRP recommendation.

This is a part of IRCNRP recommendation:
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Frequency range E-Field Strength (V ·m−1)

1-10 MHz 87/f1/2

10-400 MHz 28
400-2000 MHz 1.375f1/2

2-300 GHz 61

Figure 51: Reference level for public exposure

Frequency range E-Field Strength (V ·m−1)

1-10 MHz 610/f
10-400 MHz 61
400-2000 MHz 3f1/2

2-300 GHz 137

Figure 52: Reference level for occupational exposure

The equivalent custom standard file is

87 28 1.375 61
−0.5 0 0.5 0
10 400 2000 3
610 61 3 137
−1 0 0.5 0
10 400 2000
3

Below 1MHz, the formula is the same than the frequency range 1-10MHz. Above 300 GHz, formula
is the same than the frequency range 2-300GHz.

5.3.5 Legend

Figure 53: Legend

• Legend box displays the legend on screen.
• Color count defines the number of color displayed in legend. By default, the count is 10.
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• Coloring method

◦ Contouring
◦ Mapping

Contouring Mapping

• Transparency sliders changes transparency of all view results entities such as cross section
and iso surface.

5.3.5.1 Coloring method

The mapping method computes a color for each scalar value on the plane. A value greater or equal
to the greatest value of the range will have a red color and a value lower or equal to the lowest value
a blue color.

Figure 54: Legend in mapping coloring method

The contouring method computes a color for a range of scalar values knowing that the whole range
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is divided in several ranges. A value greater than the greatest value of the range will have a red color
whereas a value lower than the lowest value a blue color.

Figure 55: Legend in contouring coloring method

5.4 Results Menu

Figure 56: Results menu

With Results menu, the user can load the result of a computation, center of computed results and
save cross section images.

5.4.1 Save cross section

By clicking on Save cross section EMF-Visual will save images of intersection of all planes with all
volumes under the results directory See 5.3. Images are saved in PNG format.

Name of image is
CrossSection_<PlaneIndex>_volume_<VolumeIndex>_<Year><Month><Day>_<Hour><Minute><Second>.png

with
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• <PlaneIndex> is the index of the plane
• <VolumeIndex> is the index of the volume intersected by the plane
• <Year><Month><Day>_<Hour><Minute><Second> are the year, month, day, hour, minute and second

of time the Save cross section action was launched.

No image is saved under one of these conditions

• No results is loaded
• No plane is activated

The image is saved with legend, ruler to show dimensions of cross section and local frame of the
plane.

Figure 57: Example of cross section image

A grid is drawn if grid is displayed. See 5.3.1.2.3.
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Figure 58: Cross section image with grid

As the image is projected in the local frame of the cutting plane, if the cutting plane is turned, the
image is also rotated.
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Figure 59: Cross section image with rotation on cutting plane

6 Delivered features

6.1 3D database

EMF-VISUAL is delivered with a set of 3D objects to create a scene.
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Object

Basic

Building

Custom

Furniture

Ground

House

Misc

Roof

Room

Sky

Special_building

Support-Chimney

Tree
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Basic

cube.bdd

cylinder.bdd

disk.bdd

plate_h.bdd

plate_v.bdd

prism.bdd

pyramid.bdd

sphere.bdd

tetraedra.bdd

triangle.bdd
Building

building06.bdd

building07.bdd

floor_building06.bdd

gen_building01.bdd

gen_building02.bdd

gen_building03.bdd

gen_building04.bdd

gen_building05.bdd

gen_floor01.bdd

gen_floor02.bdd

gen_floor03.bdd

gen_floor04.bdd

gen_floor05.bdd

Custom

avatar.bdd

grid.bdd

ouest.bdd

planet.bdd

sud.bdd

test_2.bdd
Furniture

armchair.bdd

bed.bdd

bookcase.bdd

chair01.bdd

chair02.bdd

chest of drawers.bdd

clock.bdd

cupboard01.bdd

cupboard02.bdd

dresser.bdd

painting01.bdd

painting02.bdd

sofa.bdd

table01.bdd

table02.bdd

television.bdd

Ground

Alpes.bdd

asphalt_ground.bdd

asphalt_ground_disk.bdd

rural_ground.bdd

rural_ground_disk.bdd
House

farm1.bdd

hangar1.bdd

hangar2.bdd

house1.bdd

house2.bdd

house3.bdd

house4.bdd
Misc

car_406.bdd

car_twingo.bdd

man_standing.bdd

man_walking.bdd

woman_standing.bdd

woman_walking.bdd
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Roof

flat_roof_asphalt.bdd

flat_roof_gravel.bdd

roof_1slope.bdd

roof_2slopes_slate.bdd

roof_2slopes_tile.bdd

roof_2slopes_tile2.bdd

roof_4slopes_slate.bdd

roof_4slopes_tile_can.bdd

roof_4slopes_tile_flat.bdd
Room

bedroom.bdd

living room.bdd
Sky

Sky_blue_cyl.bdd

Sky_blue_cyl2.bdd

Sky_horizon_cyl.bdd

Sky_night_cyl.bdd

Sky_sph.bdd

Special_building

church.bdd

water_tower.bdd
Support-Chimney

chimney1.bdd

chimney2.bdd

chimney3.bdd

chimney4.bdd

mast.bdd

mast_tripod.bdd

tower.bdd

tower2.bdd

6.2 Antennas

Several kind of antennas in *.src format are delivered under Antennas directory.

6.2.1 Diagram antenna files

Several diagram files in *.elt format are delivered under Computer/Database

6.3 Recommendation files

Recommendation files are delivered under ConstraintsEnvironments directory.
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